"Chat terminated, waiting to restart..."

Aaron Gough's Avatar

Aaron Gough

07 Apr, 2011 07:48 PM

I have recently started getting this message every time I try to send a message using Propane and at regular intervals in-between. I love the application, but this bug is making it essentially unusable for me...

I have already tried removing all the Propane preferences files and restarting. The files I deleted were:
~/Library/Application Support/Propane ~/Library/Preferences/com.protocool.Propane.plist ~/Library/Caches/com.protocool.Propane

I am running OS X 10.6.7 build 10J869 on a Macbook Pro 13"

  1. Support Staff 1 Posted by trevor on 07 Apr, 2011 08:53 PM

    trevor's Avatar

    Hi Aaron,

    I'm really sorry this is happening.

    Can you supply a bit more information please?

    1 - are there other Propane users in those rooms? Are they experiencing the same problems?
    2 - If they aren't experiencing the same problems, what sets you apart (such as you're remote and they're in an office together)?
    3 - do any of your campfire host names end with '-bc'? Such as 'hoover-bc'.

    Also, can I assume this is new behaviour for and Propane was working reliably until recently?

    Thanks for your help,
    Trev

  2. 2 Posted by Aaron Gough on 07 Apr, 2011 09:07 PM

    Aaron Gough's Avatar

    Hey Trevor!
    Thanks for the quick response!

    1) There are 5 other users in the room. They're all using Propane too and haven't had any issues...
    2) We're all in the same office, and on the same wireless network. We're all running Macbook Pro 13" machines with the latest version of OS X 10.6... Nothing is really different from what I can see.
    3) None of the names seem to be unusual, they're all just our real names in full.

    Propane was working fine until maybe 3-4 days ago. I have tried restarting and all the usual stuff. Sorry I'm not able to point anything out as a potential issue...

    Thank-you!
    -A

  3. Support Staff 3 Posted by trevor on 07 Apr, 2011 11:24 PM

    trevor's Avatar

    Hey again,

    wrt question 3, I didn't mean the names of your colleagues (tho it does help to know they're regular names). I was referring to the host name in Propane's lobby window (command-o to open it) under the header of "Campfire Sites". Probably should have said "site" then shouldn't I?

    Anyhow, it's those names that I was asking about, whether any of them ended in '-bc'.

    Something in your response has piqued my interest: you say "users in the room". Does that mean that this only happens for one particular room or all rooms? If it's just one room, what's different about it? Is it on a different Campfire site/host from the others?

    Also, are you accessing Campfire with a regular web browser at the same time as running Propane?

    Along those same lines, are you using a bot that connects to Campfire as you?

    Basically, what I'm leaning towards is that there's something outside Propane clobbering your session.

    I've seen problems with the basecamp/campfire integration in the past and, as an example, if you access Campfire in Safari and then logout, it silently kills Propane's session and you don't realize until you try to send a message.

    Sorry I keep having to ask all these questions - hopefully I can track this down quickly for you.

    Regards, Trev

  4. 4 Posted by Aaron Gough on 11 Apr, 2011 02:02 PM

    Aaron Gough's Avatar

    Hey Trevor!
    None of the host names or room names end in '-bc'... The problem occurs in all the rooms, not any one in particular. It occurs across all the rooms at the same time if that's any help.

    I don't have anything that connects to Campfire as me, and I only used the web interface to Campfire on the first day, before I got Propane.

    It's weird behaviour, everyone else in the office hasn't been having any problems. I realize that it's a little hard to diagnose this from afar, so no worries there.
    -A

  5. 5 Posted by Aaron Gough on 11 Apr, 2011 08:33 PM

    Aaron Gough's Avatar

    So it seems like I have fixed this... It's possible that it was caused by the fact that some of the rooms were re-named a week or so ago, and Propane was still trying to load those room tabs on startup.

    The process that fixed it in the end was:
    * Close all tabs * Quit propane * Delete the propane app * Delete all preference files * Re-install

    You might be able to re-create the problem by re-naming campfire rooms when the application is already open.
    -A

  6. Support Staff 6 Posted by trevor on 11 Apr, 2011 08:35 PM

    trevor's Avatar

    Aaron - thanks so much for spending more time on this.

    I'll try your suggestion today and see if I can reproduce.

    Regards, Trev

  7. 7 Posted by Aaron Gough on 11 Apr, 2011 08:39 PM

    Aaron Gough's Avatar

    No worries mate, I'm a developer as well so I understand how frustrating it can be trying to troubleshoot a user's issue from a distance.

    Hopefully you're able to reproduce the issue with the info I provided, but if you can't then at least there is now a known work-around.

  8. Support Staff 8 Posted by trevor on 11 Apr, 2011 09:43 PM

    trevor's Avatar

    Hey,

    just a follow-up:

    The root of the problem is having an open tab (at startup) to a room that has been deleted.

    Instead of treating it as a plain 404, the Campfire sever is redirecting back to login, effectively clobbering the session for all of the other open rooms.

    Again, thanks for taking the time to get to the bottom of it, I know you've got better things to do than debug a chat app.

    Is there any way I can say "thanks"? Do any of your team need complimentary licenses for Propane? If you don't need any right now, just ping me next time you have someone new come on board, I'll sort them out.

    Regards, Trev

  9. 9 Posted by Aaron Gough on 11 Apr, 2011 09:57 PM

    Aaron Gough's Avatar

    Hey mate!
    It's all good, Propane is the nicest OS X client for Campfire that I've seen, so I'm happy just to have it working!

    -A

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_shot_2011-04-07_at_3.47.45_PM.png 41.8 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac