lobby window goes blank after first try

Eric Jensen's Avatar

Eric Jensen

12 Mar, 2009 04:32 PM

When I go to propane's lobby, click through to a room, and then open the lobby window again it is blank. I can click on the name of our campfire account on the left, and even get the hand and can click through on rooms to go to them, but I can't see what the rooms are...that is just a blank white pane. Also the window controls (close, min, max) don't work on it. I'm on a macbook air with 10.5.6.

Thanks, eric

  1. Support Staff 1 Posted by trevor on 12 Mar, 2009 04:39 PM

    trevor's Avatar

    Hey Eric,

    that's super-strange. Can you please check Console.app and see if there are any lines for Propane there? If so, you can highlight the lines and edit->copy them for easy pasting back here.

    The fact that window controls go dead leads me to think there's an exception buried in there somewhere (which should be logged).

    Trev

  2. 2 Posted by Eric Jensen on 12 Mar, 2009 04:53 PM

    Eric Jensen's Avatar

    Yup, opening the lobby window causes this single log line:

    3/12/09 9:52:11 AM Propane[9516] *** -[NSCFArray
    insertObject:atIndex:]: attempt to insert nil

  3. Support Staff 3 Posted by trevor on 12 Mar, 2009 05:49 PM

    trevor's Avatar

    Hi again,

    well that message isn't terribly helpful is it?

    Anyhow, in order to track this down I want to check a few things:

    1 - you're using 0.9.4 right (see Propane->About Propane)?

    2 - without opening a room, are you able to open the lobby's room listing for that host (just making sure, I think that's what you're saying)

    3 - again, without opening a room, does the lobby entry for the room you've been visiting show active users?

    4 - still not entering a room, if you press command-r when looking at the room listing, does it refresh properly? If so, does the room you were visiting show active users now?

    5 - after going into the room, is there anything 'odd' - like a blank username in the "Who's Here" list or something like that?

    Sorry for all the steps... this is a pretty odd bug, struggling to track down just which array is blowing up.

    Thanks, Trev

  4. 4 Posted by Eric Jensen on 12 Mar, 2009 06:05 PM

    Eric Jensen's Avatar

    below

  5. Support Staff 5 Posted by trevor on 12 Mar, 2009 06:13 PM

    trevor's Avatar

    Sorry Eric,

    your message only contained the word "below" - not quite sure what that means.. :-)

    Trev

  6. 6 Posted by Eric Jensen on 12 Mar, 2009 06:20 PM

    Eric Jensen's Avatar

    Sorry, i meant "i have responded to your questions in-line below".
    scroll down and you'll find said answers

  7. Support Staff 7 Posted by trevor on 12 Mar, 2009 06:26 PM

    trevor's Avatar

    Man... I'm so sorry for all the to-ing and fro-ing here.

    Tender is picky about what response text I get to see.

    I don't get to see any text below the "// Add your reply above here" line in your response. Which is to say, if you respond "inline", I don't get to see all of your response.

    Sorry to be a pain on multiple levels here, but can you put your response as the first thing in the email? Thanks so much.

    Trev

  8. 8 Posted by Eric Jensen on 12 Mar, 2009 07:11 PM

    Eric Jensen's Avatar

    ah, i ignored that comment. here you go:

    1 - you're using 0.9.4 right (see Propane->About Propane)?

    (0.9.4.3dab425)

    2 - without opening a room, are you able to open the lobby's room
    listing for that host (just making sure, I think that's what you're
    saying)

    yes

    3 - again, without opening a room, does the lobby entry for the room
    you've been visiting show active users?

    no, actually i see it hung saying "loading rooms".

    4 - still not entering a room, if you press command-r when looking
    at the room listing, does it refresh properly? If so, does the room
    you were visiting show active users now?

    no, it actually causes it to blank the list and put it in the white
    but clickable state that i described.

    5 - after going into the room, is there anything 'odd' - like a
    blank username in the "Who's Here" list or something like that?

    no

  9. Support Staff 9 Posted by trevor on 12 Mar, 2009 08:04 PM

    trevor's Avatar

    Hi Eric,

    the hanging while loading the rooms is just the clue I was looking for. I'll let you know as soon as I track down where that might go wrong.

    Thanks for your help here.

    Trev

  10. Support Staff 10 Posted by trevor on 13 Mar, 2009 12:31 AM

    trevor's Avatar

    Hi again Eric,

    okay, I think I've tracked this down to the one place where it might be happening... by the way, I assume you've still got the problem - right?

    I don't want to go into a whole long-winded explanation of the issue until we get a chance to see if I've really solved it. I've prepared a version of Propane for you to try out:

    http://propaneapp.com/appcast/Propane4Eric.zip

    Can you please try that version and let me know if it solves the problem?

    If it does, then I'd really appreciate the following info:

    1 - look in the lobby (that previously blew up). Are there any users listed under the room names in the form of user_12345? Is it just one user (in which case, what is the user_12345 string for them?) or a whole bunch (in which case, can you give me a couple of examples)?

    2 - with Safari (any browser, really), can you visit that campfire site and do a view-source on the lobby view, save that html to a file, and then put it somewhere I get to it (such as a private pastie on pastie.org)?

    Basically, if my hunch is right, I need to figure out why I'm not able to get one (or more) user's names in the lobby so I need to see that html.

    Thanks for your help, and sorry for the hassle it's causing.

    Trev

  11. 11 Posted by Eric Jensen on 13 Mar, 2009 12:36 AM

    Eric Jensen's Avatar

    works great! no users of that form, all normal full names in the
    propane lobby. the campfire lobby is attached.

    thanks! eric

  12. Support Staff 12 Posted by trevor on 13 Mar, 2009 12:53 AM

    trevor's Avatar

    Hrm...

    while I'm glad that solves the problem, the fact that you have no user_12345 style names just means that I haven't really solved it at all...

    If you've got the time (and you still have the previous version of propane installed), does the problem still happen with the old version?

    If you don't have the old version of Propane hanging around that's okay, don't put any more effort into this.

    Regards, Trev

  13. 13 Posted by Eric Jensen on 13 Mar, 2009 12:54 AM

    Eric Jensen's Avatar

    i overwrote it, sorry.

    eric.

  14. 14 Posted by Matt Dean on 16 Mar, 2009 09:10 PM

    Matt Dean's Avatar

    I can confirm that I've had the same problem (with the same error message in Console.app). The only thing I see that's different now from yesterday (when it was working) is that there's a guest user logged in with only her first name. Perhaps it's bombing when trying to determine the last name initial?

  15. 15 Posted by Eric Jensen on 16 Mar, 2009 09:11 PM

    Eric Jensen's Avatar

    FYI: this binary has fixed my problem consistently, and fixed
    another's here in the office

  16. Support Staff 16 Posted by trevor on 16 Mar, 2009 09:14 PM

    trevor's Avatar

    Matt,

    thanks for the info - is there any way you could send me your lobby's html (as seen in Safari)? The guest user may very well be an issue.

    Thanks, Trev

  17. 17 Posted by Matt Dean on 16 Mar, 2009 09:18 PM

    Matt Dean's Avatar

    http://gist.github.com/7fe1c842975133e06742

  18. 18 Posted by Matt Dean on 16 Mar, 2009 09:23 PM

    Matt Dean's Avatar

    Our single-namer just logged out and didn't fix the problem, but we still have a guest user in a different room. This time the list of rooms flashed for a few seconds before going blank, and the list didn't include the room with the guest user in it. So that'd be my guess.

  19. 19 Posted by Matt Dean on 17 Mar, 2009 01:25 AM

    Matt Dean's Avatar

    And now, after all guests have logged out, it works perfectly.

  20. Support Staff 20 Posted by trevor on 17 Mar, 2009 09:11 PM

    trevor's Avatar

    Hey guys, I've just done a new release of Propane that includes the fix that solved the problem for Eric.

    Anyone who has installed the Propane4Eric.zip build of Propane is (unfortunately) going to have to manually install the latest Propane because the update framework won't see my latest release as newer.

    You can get the most recent version from http://propaneapp.com/appcast/Propane.zip

    Sorry for all the trouble guys, let me know if you encounter any problems.

    Trev

  21. 21 Posted by Matt Dean on 17 Mar, 2009 10:26 PM

    Matt Dean's Avatar

    Perfect -- this worked for me.

    Thanks!

    Matt

  22. System closed this discussion on 30 Aug, 2013 02:01 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac