No authorized campfires after upgrade

Christian van der Leeden's Avatar

Christian van der Leeden

03 Sep, 2013 10:03 AM

Hi,

I'm reauthorizing the client and after succesfully logging in Propane says there are no authorized Campfires. I'm admin of the campfire site and have access to all rooms. I sucessfully connected with the version before the upgrade. Anything I'm missing here?

Christian
Propaneversion: Version 1.3.1 (1.3.1.b3c2e31)

  1. Support Staff 1 Posted by trevor on 03 Sep, 2013 04:11 PM

    trevor's Avatar

    Hi Christian,

    First off, sorry I didn't respond sooner (timezone differences), I know it must be frustrating.

    If you login via the website with that same username and password combination does it show you have access to any campfires?

    As a fallback, you can overwrite Propane with the prior version (1.2.5) until we get this sorted out.

    http://propaneapp.com/appcast/Propane.1.2.5.zip

    Regards,
    Trevor

  2. 2 Posted by Nathan Speed on 03 Sep, 2013 09:11 PM

    Nathan Speed's Avatar

    Hey - I'm having the exact same problem; just wanted to let you guys know. When I login to campfirenow.com I don't have any problems accessing my campfires. I'll keep using the prior version for now.

  3. Support Staff 3 Posted by trevor on 04 Sep, 2013 05:21 PM

    trevor's Avatar

    Hey,

    Are either of you behind a corporate firewall or VPN?

    Thanks,
    Trev

  4. 4 Posted by Nathan Speed on 04 Sep, 2013 05:38 PM

    Nathan Speed's Avatar

    I'm not.

  5. 5 Posted by Bernardo on 09 Sep, 2013 07:40 PM

    Bernardo's Avatar

    I am having the exact same issue.

  6. Support Staff 6 Posted by trevor on 10 Sep, 2013 01:28 AM

    trevor's Avatar

    Hi folks.

    According to my server logs it looks like a very small number of people (about 5) have re-downloaded 1.2.5 so whatever is going on is an isolated issue.

    If you're encountering this problem and have re-downloaded http://propaneapp.com/appcast/Propane.1.2.5.zip then please also be sure to let me know. I want to keep tabs on the actual number of affected users.

    In the meantime, I've prepared a new build that does more error logging while asking the server for your list of Campfires. I would really appreciate it if people experiencing the problem could try it out:

    http://propaneapp.com/appcast/Propane.1.3.2.zip

    It won't fix the issue but the extra logging should help to pin down the problem.

    Once you see the "No Authorized Campfires" message using this new build:

    • open Console.app (found in Applications/Utilities)
    • make sure "All Messages" is selected in the left pane
    • in the filter field (top-right) type "propane"
    • in the right pane, select any rows with a timestamp less than 5 minutes old (i.e. the most recent ones)
    • press command-A (select all)
    • press command-C (copy)

    Paste those log entries into a NEW support request at the bottom of http://help.propaneapp.com/discussions/propane-bugreports and make sure to check "This is a private discussion" at the top of the form.

    This is important because the log entries will contain the names of the Campfires you are accessing and may also include image URLS that were 'spoken' in your chat rooms but failed to load. It's not strictly "confidential" information but there's no point broadcasting it to the entire world.

    Thanks for your help with this, and for your patience.

    Regards,
    Trevor

  7. 7 Posted by Christian van d... on 10 Sep, 2013 08:29 AM

    Christian van der Leeden's Avatar

    Somehow it works for me now.

  8. Support Staff 8 Posted by trevor on 10 Sep, 2013 04:29 PM

    trevor's Avatar

    Christian,

    I'm glad that you're up and running on 1.3 but I'm a little troubled that I still don't know why it was failing for you...

    One last thing (that I should have asked before): do you have more than one 37signals login?

    Thanks,
    Trev

  9. 9 Posted by Nathan Speed on 10 Sep, 2013 06:04 PM

    Nathan Speed's Avatar

    I'm still having the problem on 1.3. I captured the logs using 1.3.2 as you requested and submitted a new support request. 1.2.5 continues to work for me. Thanks for looking into this!

  10. 10 Posted by Bernardo Palaci... on 10 Sep, 2013 06:58 PM

    Bernardo Palacio's Avatar

    Installed the version with logs enabled and noticed a 401. Then I tried again but using my Campfire Username (the one that appears in the Campfire User Profile) instead of my normal Username (email) used to log through the Web to Basecamp and Campfire.
    Cheers.

  11. Support Staff 11 Posted by trevor on 10 Sep, 2013 09:50 PM

    trevor's Avatar

    Folks,

    Thanks for everyone's patience while I tracked this down.

    The problem appears to be related to logging in with an email address rather than a username, as explained in this KB article:

    http://help.propaneapp.com/kb/usage/why-cant-i-login-to-my-campfires

    I'm closing this ticket and I strongly discourage anyone from continuing to use 1.2.5 because the authentication mechanism it uses will soon be disabled by 37signals.

    Thanks,
    Trevor

  12. trevor closed this discussion on 10 Sep, 2013 09:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac